about summary refs log tree commit diff stats
path: root/hm/soispha/conf/taskwarrior/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/taskwarrior/default.nix')
-rw-r--r--hm/soispha/conf/taskwarrior/default.nix22
1 files changed, 16 insertions, 6 deletions
diff --git a/hm/soispha/conf/taskwarrior/default.nix b/hm/soispha/conf/taskwarrior/default.nix
index 78bcacd0..3d647482 100644
--- a/hm/soispha/conf/taskwarrior/default.nix
+++ b/hm/soispha/conf/taskwarrior/default.nix
@@ -1,4 +1,8 @@
 {...}: {
+  imports = [
+    ./hooks
+  ];
+
   programs.taskwarrior = let
     mkContext = project: {
       inherit (project) name;
@@ -13,6 +17,7 @@
     context = builtins.listToAttrs (builtins.map mkContext (import ./projects {}));
   in {
     enable = true;
+    colorTheme = ./nord.theme;
     config = {
       news.version = "2.6.0";
       complete.all.tags = true;
@@ -23,17 +28,22 @@
       regex = true;
       weekstart = "Monday";
       uda = {
-        neorg = {
-          type = "string";
-          label = "Neorg";
+        total_active_time = {
+          type = "duration";
+          label = "Total active time";
         };
       };
+      alias = {
+        a = "add";
+        bd = "burndown.daily";
+        cx = "context";
+        e = "edit";
+        mod = "modify";
+        n = "execute neorg --task";
+      };
       color = true;
 
       inherit context;
     };
-    extraConfig = ''
-      include ${./nord.theme}
-    '';
   };
 }