about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/plgs/leap/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/nvim/plgs/leap/default.nix57
1 files changed, 29 insertions, 28 deletions
diff --git a/hm/soispha/conf/nvim/plgs/leap/default.nix b/hm/soispha/conf/nvim/plgs/leap/default.nix
index bffdf33c..568dcec0 100644
--- a/hm/soispha/conf/nvim/plgs/leap/default.nix
+++ b/hm/soispha/conf/nvim/plgs/leap/default.nix
@@ -26,33 +26,34 @@
         "Z"
       ];
     };
-    maps = {
-      normalVisualOp = {
-        "m" = {
-          action = "<Plug>(leap-forward-to)";
-          desc = "leap forward to";
-        };
-        "M" = {
-          action = "<Plug>(leap-backward-to)";
-          desc = "leap backward to";
-        };
-        "gs" = {
-          action = "<Plug>(leap-from-window)";
-          desc = "leap to enterable windows";
-        };
-      };
-      visual = {
-        /*
-        "x" = {
-          action = "<Plug>(leap-forward-till)";
-          desc = "leap forward till";
-        };
-        "X" = {
-          action = "<Plug>(leap-backward-till)";
-          desc = "leap backward till";
-        };
-        */
-      };
-    };
+    keymaps = [
+      {
+        key = "m";
+        action = "<Plug>(leap-forward-to)";
+        options.desc = "leap forward to";
+      }
+      {
+        key = "M";
+        action = "<Plug>(leap-backward-to)";
+        options.desc = "leap backward to";
+      }
+      {
+        key = "gs";
+        action = "<Plug>(leap-from-window)";
+        options.desc = "leap to enterable windows";
+      }
+      /*
+            {key= "x";
+              mode = "v";
+              action = "<Plug>(leap-forward-till)";
+      options.desc = "leap forward till";
+            }
+            {key= "X";
+              mode = "v";
+              action = "<Plug>(leap-backward-till)";
+      options.desc = "leap backward till";
+            }
+      */
+    ];
   };
 }