about summary refs log tree commit diff stats
path: root/hm/soispha/conf/nvim/files/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/nvim/files/default.nix')
-rw-r--r--hm/soispha/conf/nvim/files/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hm/soispha/conf/nvim/files/default.nix b/hm/soispha/conf/nvim/files/default.nix
new file mode 100644
index 00000000..5045eb9f
--- /dev/null
+++ b/hm/soispha/conf/nvim/files/default.nix
@@ -0,0 +1,17 @@
+{
+  lib,
+  pkgs,
+  ...
+}: {
+  programs.nixvim = {
+    extraPlugins = [
+      pkgs.vimExtraPlugins.gruvbox
+    ];
+    extraFiles = {
+      path = "ftplugin/tex.lua";
+      content = ''
+        ${lib.strings.fileContents ./ftplugin/tex.lua}
+      '';
+    };
+  };
+}