about summary refs log tree commit diff stats
path: root/hm/soispha/conf/mail/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/mail/default.nix')
-rw-r--r--hm/soispha/conf/mail/default.nix55
1 files changed, 3 insertions, 52 deletions
diff --git a/hm/soispha/conf/mail/default.nix b/hm/soispha/conf/mail/default.nix
index 7ca65e1a..0ecbe40a 100644
--- a/hm/soispha/conf/mail/default.nix
+++ b/hm/soispha/conf/mail/default.nix
@@ -1,61 +1,12 @@
 {
   config,
   pkgs,
-  lib,
   ...
 }: let
-  non_public_accounts = import ./non_public_accounts.nix {inherit pkgs;};
-  accounts = lib.recursiveUpdate {inherit soispha;} non_public_accounts;
+  benedikt = import ./accounts/benedikt.nix {inherit pkgs;};
+  soispha = import ./accounts/soispha.nix {inherit pkgs;};
 
-  soispha = {
-    address = "soispha@vhack.eu";
-    userName = "soispha@vhack.eu";
-    realName = "Soispha";
-    primary = true;
-    passwordCommand = "${pkgs.libsecret}/bin/secret-tool lookup account soispha@vhack.eu";
-    aliases = [
-      "admin@vhack.eu"
-    ];
-    folders = {
-    };
-    gpg = {
-      encryptByDefault = true;
-      key = "9606FC749FCE16360723D4ADA5E94010C3A642AD";
-      signByDefault = true;
-    };
-    signature = {
-      # TODO:
-    };
-    neomutt = {
-      enable = true;
-    };
-    mbsync = {
-      enable = true;
-      create = "both";
-    };
-    # himalaya = {
-    #   enable = true;
-    #   backend = "imap";
-    #   sender = "smtp";
-    #   settings = {
-    #     # TODO:
-    #   };
-    # };
-    smtp = {
-      host = "server1.vhack.eu";
-      port = 465;
-    };
-    imap = {
-      host = "server1.vhack.eu";
-      port = 993;
-    };
-    jmap = {
-      # TODO:
-    };
-    maildir = {
-      path = "soispha";
-    };
-  };
+  accounts = {inherit soispha benedikt;};
 in {
   accounts.email = {
     maildirBasePath = "${config.xdg.dataHome}/maildir";