about summary refs log tree commit diff stats
path: root/hm/soispha/conf/less/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/less/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/hm/soispha/conf/less/default.nix b/hm/soispha/conf/less/default.nix
index 1d598995..f4103080 100644
--- a/hm/soispha/conf/less/default.nix
+++ b/hm/soispha/conf/less/default.nix
@@ -2,16 +2,16 @@
   home.sessionVariables = {
     PAGER = "less";
     MANPAGER = "less --color=d+r --color=u+b";
+
+    # These are added here because adding them in the lesskey file somehow doesn't work.
+    LESSHISTSIZE = 10000;
+    LESSHISTFILE = "${config.xdg.dataHome}/less/history";
   };
   programs.less = {
     enable = true;
     keys =
       builtins.readFile ./command.less
       + builtins.readFile ./line-edit.less
-      + builtins.readFile ./env.less
-      # This next line *must* be under the `./env.less` include, as it extends the environment definitions
-      + ''
-        LESSHISTFILE = ${config.xdg.dataHome}/less/history
-      '';
+      + builtins.readFile ./env.less;
   };
 }