about summary refs log tree commit diff stats
path: root/hm/soispha/conf/gpg/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/soispha/conf/gpg/default.nix')
-rw-r--r--hm/soispha/conf/gpg/default.nix32
1 files changed, 9 insertions, 23 deletions
diff --git a/hm/soispha/conf/gpg/default.nix b/hm/soispha/conf/gpg/default.nix
index ffc90ffe..15be872b 100644
--- a/hm/soispha/conf/gpg/default.nix
+++ b/hm/soispha/conf/gpg/default.nix
@@ -2,19 +2,12 @@
   config,
   pkgs,
   ...
-}: let
-  gpg-agent = {
-    enable = true;
-    enableZshIntegration = true;
-    enableScDaemon = true; # smartcards and such things
-    pinentryPackage = pkgs.pinentry-tty;
-  };
-in {
+}: {
   programs.gpg = {
     enable = true;
     homedir = "${config.xdg.dataHome}/gnupg/onlykey";
-    mutableKeys = false;
-    mutableTrust = false;
+    mutableKeys = true;
+    mutableTrust = true;
 
     settings = {
       default-key = "Benedikt Peetz <benedikt.peetz@b-peetz.de>";
@@ -23,24 +16,17 @@ in {
 
     publicKeys = [
       {
-        source = ./keys/key_1;
-        trust = "ultimate";
-      }
-      {
         source = ./keys/key_2;
-        trust = "ultimate";
-      }
-      {
-        source = ./keys/key_3;
-        trust = "full";
-      }
-      {
-        source = ./keys/key_4;
         trust = "full";
       }
     ];
   };
   services = {
-    inherit gpg-agent;
+    gpg-agent = {
+      enable = true;
+      enableZshIntegration = true;
+      enableScDaemon = true; # smartcards and such things
+      pinentryPackage = pkgs.pinentry-tty;
+    };
   };
 }