about summary refs log tree commit diff stats
path: root/hm/soispha/conf/git/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/git/default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/hm/soispha/conf/git/default.nix b/hm/soispha/conf/git/default.nix
index 46f272eb..eda42210 100644
--- a/hm/soispha/conf/git/default.nix
+++ b/hm/soispha/conf/git/default.nix
@@ -2,16 +2,26 @@
   nixosConfig,
   lib,
   config,
+  sysLib,
+  pkgs,
   ...
 }: let
   gitIgnoreFile = ./git_ignore.git;
   gitTemplateFile = ./git_template.git;
+  commit = sysLib.writeShellScriptWithLibraryAndKeepPath {
+    name = "commit";
+    src = ./scripts/commit;
+    dependencies = with pkgs; [
+      git
+      gnused
+    ];
+  };
 in {
   programs.git = {
     enable = true;
     #package = pkgs.gitAndTools.gitFull; # TODO: for git send-email support
     aliases = {
-      cm = "commit --verbose";
+      cm = "!${commit}/bin/commit";
       cmr = "commit --file .git/COMMIT_EDITMSG --edit --verbose";
 
       st = "status";