about summary refs log tree commit diff stats
path: root/hm/soispha/conf/alacritty/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/alacritty/default.nix33
1 files changed, 14 insertions, 19 deletions
diff --git a/hm/soispha/conf/alacritty/default.nix b/hm/soispha/conf/alacritty/default.nix
index 9048fc34..c1cf5e44 100644
--- a/hm/soispha/conf/alacritty/default.nix
+++ b/hm/soispha/conf/alacritty/default.nix
@@ -1,23 +1,18 @@
 {lib, ...}: let
-  # NOTE: The `colorscheme.yml` import __needs__ to be __after__ the `colors.yml` import, otherwise, applying it wont
-  # work. <2023-08-28>
   config_file = ''
-    ${lib.strings.fileContents ./yaml/base.yml}
-    ${lib.strings.fileContents ./yaml/bell.yml}
-    ${lib.strings.fileContents ./yaml/colors.yml}
-    ${lib.strings.fileContents ./yaml/colorscheme.yml}
-    ${lib.strings.fileContents ./yaml/cursor.yml}
-    ${lib.strings.fileContents ./yaml/debug.yml}
-    ${lib.strings.fileContents ./yaml/env.yml}
-    ${lib.strings.fileContents ./yaml/font.yml}
-    ${lib.strings.fileContents ./yaml/hints.yml}
-    ${lib.strings.fileContents ./yaml/key_bindings.yml}
-    ${lib.strings.fileContents ./yaml/mouse.yml}
-    ${lib.strings.fileContents ./yaml/mouse_bindings.yml}
-    ${lib.strings.fileContents ./yaml/scrolling.yml}
-    ${lib.strings.fileContents ./yaml/selection.yml}
-    ${lib.strings.fileContents ./yaml/shell.yml}
-    ${lib.strings.fileContents ./yaml/window.yml}
+    ${lib.strings.fileContents ./toml/base.toml}
+    ${lib.strings.fileContents ./toml/bell.toml}
+    ${lib.strings.fileContents ./toml/colorscheme.toml}
+    ${lib.strings.fileContents ./toml/cursor.toml}
+    ${lib.strings.fileContents ./toml/env.toml}
+    ${lib.strings.fileContents ./toml/font.toml}
+    ${lib.strings.fileContents ./toml/hints.toml}
+    ${lib.strings.fileContents ./toml/keyboard_bindings.toml}
+    ${lib.strings.fileContents ./toml/mouse.toml}
+    ${lib.strings.fileContents ./toml/mouse_bindings.toml}
+    ${lib.strings.fileContents ./toml/scrolling.toml}
+    ${lib.strings.fileContents ./toml/selection.toml}
+    ${lib.strings.fileContents ./toml/window.toml}
   '';
 in {
   home.sessionVariables = {
@@ -31,5 +26,5 @@ in {
   programs.alacritty = {
     enable = true;
   };
-  xdg.configFile."alacritty/alacritty.yml".text = config_file;
+  xdg.configFile."alacritty/alacritty.toml".text = config_file;
 }