about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index a8be86e4..d08eb34a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -246,6 +246,15 @@
         flake-compat.follows = "flake-compat";
       };
     };
+    qmk_firmware = {
+      url = "git+https://git.foss-syndicate.org/bpeetz/qmk_layout.git?ref=prime";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        treefmt-nix.follows = "treefmt-nix";
+        systems.follows = "systems";
+        flake-utils.follows = "flake-utils";
+      };
+    };
 
     # external resources
     user_js = {
@@ -286,6 +295,7 @@
     # my binaries
     shell_library,
     river_init_lesser,
+    qmk_firmware,
     ...
   }: let
     system = "x86_64-linux";
@@ -337,6 +347,7 @@
         # my binaries
         shell_library
         river_init_lesser
+        qmk_firmware
         ;
     };
   in