about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 59efc128..6dd46d91 100644
--- a/flake.nix
+++ b/flake.nix
@@ -194,12 +194,10 @@
       };
     };
     lanzaboote = {
-      # TODO: Subscribe to their update feed. <2024-12-18>
-      url = "github:nix-community/lanzaboote/v0.4.1";
+      url = "github:nix-community/lanzaboote/v0.4.2";
       inputs = {
         nixpkgs.follows = "nixpkgs-stable";
         flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
         flake-parts.follows = "flake-parts";
         crane.follows = "crane";
         rust-overlay.follows = "rust-overlay";
@@ -299,6 +297,8 @@
     system = "x86_64-linux";
     sysLib = shell_library.lib.${system};
 
+    baseLib = import ./lib {inherit (pkgs) lib;};
+
     inherit (library) nixLib;
 
     pkgsStable = nixpkgs-stable.legacyPackages.${system};
@@ -325,6 +325,7 @@
         myPkgs
         system
         sysLib
+        baseLib
         nixpkgs_as_input
         nixpkgs_open_prs
         # modules