about summary refs log tree commit diff stats
path: root/bootstrap/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--bootstrap/default.nix49
1 files changed, 0 insertions, 49 deletions
diff --git a/bootstrap/default.nix b/bootstrap/default.nix
deleted file mode 100644
index a5492290..00000000
--- a/bootstrap/default.nix
+++ /dev/null
@@ -1,49 +0,0 @@
-# nixos-config - My current NixOS configuration
-#
-# Copyright (C) 2025 Benedikt Peetz <benedikt.peetz@b-peetz.de>
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This file is part of my nixos-config.
-#
-# You should have received a copy of the License along with this program.
-# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
-{
-  pkgs,
-  sysLib,
-  ...
-}: let
-  ensure_config_variables_dependencies = builtins.attrValues {inherit (pkgs) systemd jq dash gnugrep curl;};
-  replacementStrings = {SCRIPT_ENSURE_CONFIG_VARIABLES = "${ensure_config_variables}/bin/ensure_config_variables";};
-  activate = sysLib.writeShellScript {
-    dependencies = with pkgs; [jq gawk curl coreutils libuuid lix git] ++ ensure_config_variables_dependencies;
-    name = "activate";
-    src = ./01_activate.sh;
-    inherit replacementStrings;
-  };
-  install = sysLib.writeShellScript {
-    dependencies = with pkgs; [jq dash curl gawk btrfs-progs coreutils libuuid gptfdisk dosfstools toybox lix git] ++ ensure_config_variables_dependencies;
-    name = "install";
-    src = ./01_install.sh;
-    inherit replacementStrings;
-  };
-  setup = sysLib.writeShellScript {
-    dependencies = with pkgs; [dash gawk curl git lix gnugrep nixos-install-tools coreutils libuuid] ++ ensure_config_variables_dependencies;
-    name = "setup";
-    src = ./02_setup.sh;
-    inherit replacementStrings;
-  };
-  config_setup = sysLib.writeShellScript {
-    dependencies = builtins.attrValues {inherit (pkgs) git neovim;} ++ ensure_config_variables_dependencies;
-    name = "config_setup";
-    src = ./03_config_setup.sh;
-    keepPath = true;
-    inherit replacementStrings;
-  };
-  ensure_config_variables = sysLib.writeShellScript {
-    name = "ensure_config_variables";
-    src = ./99_ensure_config_variables.sh;
-    wrap = false;
-  };
-  output = {inherit activate install setup config_setup ensure_config_variables;};
-in
-  output