about summary refs log tree commit diff stats
path: root/system/users.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-01 20:22:29 +0100
committerene <ene@sils.li>2023-02-01 20:28:24 +0100
commita806c6776ea19ec068b7a60fde211310fd41d156 (patch)
treeb34083424e759459473b13b7c2f9f75cf9e8a80e /system/users.nix
downloadnixos-config-a806c6776ea19ec068b7a60fde211310fd41d156.zip
Initial commit
Diffstat (limited to '')
-rw-r--r--system/users.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/system/users.nix b/system/users.nix
new file mode 100644
index 00000000..ca2fc352
--- /dev/null
+++ b/system/users.nix
@@ -0,0 +1,17 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  users = {
+    mutableUsers = false;
+    users.soispha = {
+      isNormalUser = true;
+      home = "/home/soispha";
+      shell = pkgs.zsh;
+      initialHashedPassword = "$y$jFT$ONrCqZIJKB7engmfA4orD/$0GO58/wV5wrYWj0cyONhyujZPjFmbT0XKtx2AvXLG0B";
+      extraGroups = ["wheel"];
+      uid = 1000;
+    };
+  };
+}