about summary refs log tree commit diff stats
path: root/pkgs/sources/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-23 13:26:22 +0200
commit204731c0a69136c9cebcb54f1afecf5145e26bbe (patch)
treefc9132e5dc74e4a8e1327cdd411839a90f9410aa /pkgs/sources/default.nix
parentrefactor(sys): Modularize and move to `modules/system` or `pkgs` (diff)
downloadnixos-config-204731c0a69136c9cebcb54f1afecf5145e26bbe.zip
refactor(pkgs): Categorize into `by-name` shards
This might not be the perfect way to organize a package set --
especially if the set is not nearly the size of nixpkgs -- but it is
_at_ least a way of organization.
Diffstat (limited to '')
-rw-r--r--pkgs/sources/default.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/pkgs/sources/default.nix b/pkgs/sources/default.nix
deleted file mode 100644
index 4668d735..00000000
--- a/pkgs/sources/default.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{
-  homeConfig,
-  nixosConfig,
-  sysLib,
-}: let
-  comments = import ./comments;
-  generate_firefox_extensions = import ./generate_moz_extension;
-  lf_make_map = import ./lf-make-map;
-  nvim_plugs = import ./plgs-pkgs;
-  scripts = import ./scripts {inherit sysLib homeConfig nixosConfig;};
-  snap-sync-forked = (import ./snap-sync-forked) {inherit sysLib;};
-  update_vim_plugins = import ./update_vim_plugins;
-  yt = import ./yt;
-  yts-grammar = import ./tree-sitter-yts;
-
-  overlays =
-    comments
-    ++ generate_firefox_extensions
-    ++ lf_make_map
-    ++ nvim_plugs
-    ++ scripts
-    ++ snap-sync-forked
-    ++ update_vim_plugins
-    ++ yt
-    ++ yts-grammar;
-in
-  overlays