about summary refs log tree commit diff stats
path: root/modules/system/disks/default.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:10:21 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-05-20 16:14:26 +0200
commit368cb6b0d25db2ae23be42ad51584de059997e51 (patch)
tree3282e45d3ebced63c8498a47e83a255c35de620b /modules/system/disks/default.nix
parentrefactor(hm): Rename to `modules/home` (diff)
downloadnixos-config-368cb6b0d25db2ae23be42ad51584de059997e51.zip
refactor(sys): Modularize and move to `modules/system` or `pkgs`
Diffstat (limited to '')
-rw-r--r--modules/system/disks/default.nix (renamed from sys/disks/default.nix)18
1 files changed, 7 insertions, 11 deletions
diff --git a/sys/disks/default.nix b/modules/system/disks/default.nix
index 2283db96..c0e5bcfd 100644
--- a/sys/disks/default.nix
+++ b/modules/system/disks/default.nix
@@ -14,29 +14,25 @@
 in {
   options.soispha.disks = {
     enable = lib.mkEnableOption "disk setup with disko";
+
     disk = lib.mkOption {
       type = lib.types.path;
       example = lib.literalExpression "/dev/disk/by-uuid/0442cb6d-f13a-4635-b487-fa76189774c5";
-      description = ''
-        The disk used for installing the OS.
-      '';
-    };
-    ssd = lib.mkOption {
-      type = lib.types.bool;
-      example = lib.literalExpression "true";
-      default = false;
-      description = lib.mdDoc "Enable ssd specific improvements, like trim";
+      description = "The disk used for installing the OS.";
     };
+
+    ssd = lib.mkEnableOption "ssd specific improvements, like trim";
+
     swap = {
       uuid = lib.mkOption {
         type = lib.types.str;
         example = lib.literalExpression "d1d20ae7-3d8a-44da-86da-677dbbb10c89";
-        description = lib.mdDoc "The uuid of the swapfile";
+        description = "The uuid of the swapfile";
       };
       resumeOffset = lib.mkOption {
         type = lib.types.str;
         example = lib.literalExpression "134324224";
-        description = lib.mdDoc "The resume offset of the swapfile";
+        description = "The resume offset of the swapfile";
       };
     };
   };