about summary refs log tree commit diff stats
path: root/modules/by-name/ts/tskm/module.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-04 18:07:10 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-04-04 18:07:10 +0200
commit649c3c5a7fa1d02893d10c59adb709da49f504c8 (patch)
tree7a794119bb739d5a72f0555112374c68b502ee79 /modules/by-name/ts/tskm/module.nix
parentfix(modules/firefox): Sort the languages according to my preference (diff)
downloadnixos-config-649c3c5a7fa1d02893d10c59adb709da49f504c8.zip
fix(modules/tskm): Allocate Firefox profile id's consecutively
Firefox apparently needs to have ID's staring from 0 and then counting
up. This seems like an implementation detail leaking out, but … well
it's Firefox.
Diffstat (limited to '')
-rw-r--r--modules/by-name/ts/tskm/module.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/modules/by-name/ts/tskm/module.nix b/modules/by-name/ts/tskm/module.nix
index 75af4509..51be48fe 100644
--- a/modules/by-name/ts/tskm/module.nix
+++ b/modules/by-name/ts/tskm/module.nix
@@ -2,7 +2,6 @@
   lib,
   config,
   pkgs,
-  baseLib,
   ...
 }: let
   cfg = config.soispha.programs.tskm;
@@ -15,13 +14,11 @@
   in
     [name] ++ subprojects;
 
-  firefoxProfiles = builtins.listToAttrs (builtins.map (name:
+  firefoxProfiles = builtins.listToAttrs (lib.imap0 (index: name:
     lib.attrsets.nameValuePair name {
       inherit name;
-      # We use the hash-based function here, so that we can avoid an id change if a new
-      # profile is added (i.e., simply using it index.)
-      # TODO: However, I do not know what this id is for and if it would be bad if it changed? <2025-04-02>
-      id = baseLib.idFromString name;
+      # Add one here, so that we can have the default profile at id 0.
+      id = index + 1;
     })
   allProjectNames);