about summary refs log tree commit diff stats
path: root/hosts/mammun_on_vm/hardware/gpu.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-26 12:22:58 +0100
committerene <ene@sils.li>2023-02-26 12:24:36 +0100
commite22f4574f69b83c34940817c3bf0ce89ec2e7d5b (patch)
tree93ae6580205ec801a87f40baea7b86edd978e559 /hosts/mammun_on_vm/hardware/gpu.nix
parentFix(hosts/mammun): Use amdgpu driver (diff)
downloadnixos-config-e22f4574f69b83c34940817c3bf0ce89ec2e7d5b.zip
Feat(hosts): Added mammun for the vm config
Diffstat (limited to '')
-rw-r--r--hosts/mammun_on_vm/hardware/gpu.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hosts/mammun_on_vm/hardware/gpu.nix b/hosts/mammun_on_vm/hardware/gpu.nix
new file mode 100644
index 00000000..d744962c
--- /dev/null
+++ b/hosts/mammun_on_vm/hardware/gpu.nix
@@ -0,0 +1,15 @@
+# vim: ts=2
+{pkgs, ...}: {
+  boot.initrd.kernelModules = ["amdgpu"];
+  # for Southern Islands (SI ie. GCN 1) cards and for Sea Islands (CIK ie. GCN 2) cards
+  boot.kernelParams = ["radeon.si_support=0" "amdgpu.si_support=1" "radeon.cik_support=0" "amdgpu.cik_support=1"];
+
+  hardware.opengl.driSupport = true;
+  # For 32 bit applications
+  hardware.opengl.driSupport32Bit = true;
+
+  hardware.opengl.extraPackages = with pkgs; [
+    rocm-opencl-icd
+    rocm-opencl-runtime
+  ];
+}