about summary refs log tree commit diff stats
path: root/hosts/mammun/hardware/default.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-20 11:06:12 +0100
committerene <ene@sils.li>2023-02-20 11:06:12 +0100
commit504d48d19b448203f8f1a59b2c1e3580908ad8c4 (patch)
tree68e97eee2d619c6908f8f7f35d3be210ca548363 /hosts/mammun/hardware/default.nix
parentFeat(flake): Move the nixosConfigurations to a file (diff)
downloadnixos-config-504d48d19b448203f8f1a59b2c1e3580908ad8c4.zip
Fix(hosts): Use correct names and add mammun
Diffstat (limited to '')
-rw-r--r--hosts/mammun/hardware/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/hosts/mammun/hardware/default.nix b/hosts/mammun/hardware/default.nix
new file mode 100644
index 00000000..bd7241b3
--- /dev/null
+++ b/hosts/mammun/hardware/default.nix
@@ -0,0 +1,28 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}: {
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
+    ./cpu.nix
+    ./gpu.nix
+  ];
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+
+  system.fileSystemLayouts = {
+    enable = true;
+    mainDisk = "/dev/disk/by-uuid/<uuid>";
+    efiDisk = "/dev/disk/by-uuid/<uuid>";
+  };
+
+  boot = {
+    kernelModules = ["kvm-amd"];
+
+    # TODO check this:
+    initrd.availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
+  };
+}