about summary refs log tree commit diff stats
path: root/hosts/IDOHVE/hardware/hardware.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-01 21:33:11 +0100
committerene <ene@sils.li>2023-02-03 17:34:11 +0100
commit871d3f95963eac25765427ecca9a8e4812071439 (patch)
tree5dcf241ece31050cf0c74219852242abe504e068 /hosts/IDOHVE/hardware/hardware.nix
parentBuild(flake): Added Flake.lock (diff)
downloadnixos-config-871d3f95963eac25765427ecca9a8e4812071439.zip
Feat: Split the config apart
Diffstat (limited to '')
-rw-r--r--hosts/IDOHVE/hardware/hardware.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/hosts/IDOHVE/hardware/hardware.nix b/hosts/IDOHVE/hardware/hardware.nix
new file mode 100644
index 00000000..20e4c4f3
--- /dev/null
+++ b/hosts/IDOHVE/hardware/hardware.nix
@@ -0,0 +1,19 @@
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}:{
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix") # TODO is this necessary?
+    ./cpu.nix
+    ./gpu.nix
+    ./boot.nix
+    ./filesystems.nix
+  ];
+
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}
+