about summary refs log tree commit diff stats
path: root/home-manager/soispha/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-22 19:39:25 +0200
committerSoispha <soispha@vhack.eu>2023-08-22 19:55:48 +0200
commit4c9eaeab4d71a8b3f74b373c42b35f28cd7bb803 (patch)
tree94db1db9569e0f249ea0922b999f6c3ce025ea25 /home-manager/soispha/default.nix
parentFeat(flake): Provide the neovim config as a package (diff)
downloadnixos-config-4c9eaeab4d71a8b3f74b373c42b35f28cd7bb803.zip
Feat(hm/conf/xdg): Set up userDirs
Diffstat (limited to '')
-rw-r--r--home-manager/soispha/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/home-manager/soispha/default.nix b/home-manager/soispha/default.nix
index 1efb2ca2..0ef53489 100644
--- a/home-manager/soispha/default.nix
+++ b/home-manager/soispha/default.nix
@@ -39,5 +39,23 @@ in {
   xdg = {
     inherit configHome dataHome stateHome cacheHome; #binHome; # TODO add binHome, when the standart is extended
     enable = true;
+
+    /*
+    TODO add this
+    desktopEntries = {};
+    */
+
+    userDirs = {
+      enable = true;
+      createDirectories = true;
+      desktop = null;
+      documents = "${homeDirectory}/school/general";
+      download = "${homeDirectory}/media/downloads";
+      music = "${homeDirectory}/media/music";
+      pictures = "${homeDirectory}/media/pictures";
+      videos = "${homeDirectory}/media/videos";
+      templates = "${homeDirectory}/media/templates";
+      publicShare = "${homeDirectory}/media/public";
+    };
   };
 }