about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/neovim/nixneovim/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-19 21:53:09 +0200
committerSoispha <soispha@vhack.eu>2023-08-19 21:53:09 +0200
commit5e788e0eabec1073bf1861fcd1a11b31955ad840 (patch)
tree4eeb20774060443e3e67afd1d7f244b34e0bef28 /home-manager/soispha/config/neovim/nixneovim/default.nix
parentFix(hm/conf/neovim/plugins/lsp): Remove duplicated setup of capabilities (diff)
downloadnixos-config-5e788e0eabec1073bf1861fcd1a11b31955ad840.zip
Fix(hm/conf/neovim/nixneovim): Remove as it's replaced by nixvim
Diffstat (limited to '')
-rw-r--r--home-manager/soispha/config/neovim/nixneovim/default.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/home-manager/soispha/config/neovim/nixneovim/default.nix b/home-manager/soispha/config/neovim/nixneovim/default.nix
deleted file mode 100644
index bd10b36d..00000000
--- a/home-manager/soispha/config/neovim/nixneovim/default.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{
-  lib,
-  pkgs,
-  ...
-}: {
-  imports = [
-    ./options
-    ./mappings
-  ];
-  # TODO package nightfox though a module
-  programs.nixneovim = {
-    enable = true;
-    defaultEditor = true;
-    extraConfigLuaPost = ''
-      ${lib.strings.fileContents ./lua/nightfox.lua}
-    '';
-
-    # to install plugins just activate their modules
-    plugins = {
-      lsp = {
-        enable = true;
-        hls.enable = true;
-        rust-analyzer.enable = true;
-      };
-      treesitter = {
-        enable = true;
-        indent = true;
-      };
-      mini = {
-        enable = true;
-        ai.enable = true;
-        jump.enable = true;
-      };
-    };
-
-    # Not all plugins have own modules
-    # You can add missing plugins here
-    # `pkgs.vimExtraPlugins` is added by the overlay you added at the beginning
-    # For a list of available plugins, look here: [available plugins](https://github.com/jooooscha/nixpkgs-vim-extra-plugins/blob/main/plugins.md)
-    extraPlugins = [pkgs.vimExtraPlugins.nightfox-nvim];
-  };
-}