about summary refs log tree commit diff stats
path: root/home-manager/soispha/config/lf/commands/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-08-19 23:07:51 +0200
committerSoispha <soispha@vhack.eu>2023-08-19 23:07:51 +0200
commita082c240d12541d12969a383d182eaccf913fa32 (patch)
tree4801d591729178b7030aa56a30b2607b0f328f20 /home-manager/soispha/config/lf/commands/default.nix
parentFix(hm/conf/lf/commands): Correctly quote the id string in 'fzf_jump' cmd (diff)
downloadnixos-config-a082c240d12541d12969a383d182eaccf913fa32.zip
Fix(hm/conf/lf): Split file creation and edit of the made file cmds
I mostly create files from vim, thus editing them in the terminal with
created them is useless.
Diffstat (limited to '')
-rw-r--r--home-manager/soispha/config/lf/commands/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/home-manager/soispha/config/lf/commands/default.nix b/home-manager/soispha/config/lf/commands/default.nix
index c60b0039..c8652442 100644
--- a/home-manager/soispha/config/lf/commands/default.nix
+++ b/home-manager/soispha/config/lf/commands/default.nix
@@ -18,6 +18,7 @@
       inherit replacementStrings;
     }
     + "/bin/${builtins.baseNameOf file}";
+
   shell = {
     file,
     dependencies,
@@ -143,6 +144,10 @@ in {
     file = ./scripts/mk_file;
     dependencies = [];
   };
+  mk_file_and_edit = shell {
+    file = ./scripts/mk_file_and_edit;
+    dependencies = [];
+  };
   mk_ln = pipe {
     file = ./scripts/mk_ln;
     dependencies = [];