about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-02-23 21:08:17 +0100
committerSoispha <soispha@vhack.eu>2024-02-23 21:18:42 +0100
commitc0659d7fc7690087e5412ba26488aa3a157df476 (patch)
tree68d8df290b00f775b674be1e95e425ce92b0c97b /hm/soispha/pkgs/scripts
parentrefactor(hm/conf/lf): Move configs to `settings` attr (diff)
downloadnixos-config-c0659d7fc7690087e5412ba26488aa3a157df476.zip
feat(hm/pkgs/mpc): Init
Diffstat (limited to '')
-rw-r--r--hm/soispha/pkgs/scripts.nix11
-rwxr-xr-xhm/soispha/pkgs/scripts/wrappers/mpc.sh20
2 files changed, 31 insertions, 0 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index 73dadc0a..5bcb82e0 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -180,6 +180,16 @@
     };
   };
 
+  mpc-scr = write_shell {
+    name = "mpc";
+    path = "wrappers";
+    dependencies = [
+      mpc-fav-scr
+      mpc-rm-scr
+      pkgs.mpc-cli
+    ];
+  };
+
   nato-scr = write_python {
     name = "nato";
     path = "small_functions";
@@ -305,6 +315,7 @@ in [
   lyrics-scr
   mpc-fav-scr
   mpc-rm-scr
+  mpc-scr
   nato-scr
   neorg-scr
   screenshot_persistent-scr
diff --git a/hm/soispha/pkgs/scripts/wrappers/mpc.sh b/hm/soispha/pkgs/scripts/wrappers/mpc.sh
new file mode 100755
index 00000000..b870150b
--- /dev/null
+++ b/hm/soispha/pkgs/scripts/wrappers/mpc.sh
@@ -0,0 +1,20 @@
+#!/usr/bin/env dash
+
+# shellcheck source=/dev/null
+SHELL_LIBRARY_VERSION="2.0.13" . %SHELL_LIBRARY_PATH
+
+case "$1" in
+"rm")
+    shift 1
+    mpc-rm "$@"
+    ;;
+"fav")
+    shift 1
+    mpc-fav "$@"
+    ;;
+*)
+    mpc "$@"
+    ;;
+esac
+
+# vim: ft=sh