about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/scripts.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-02-23 21:13:20 +0100
committerSoispha <soispha@vhack.eu>2024-02-23 21:18:47 +0100
commit17d0ff761fee6a921a210e68c21c1a172bba2dfa (patch)
treeea1f6b11b48cd7571cd4a220a1e435735d9c24db /hm/soispha/pkgs/scripts.nix
parentfeat(hm/conf/unison): Add support for link syncing (diff)
downloadnixos-config-17d0ff761fee6a921a210e68c21c1a172bba2dfa.zip
feat(hm/pkgs/git-edit-index): Init
Diffstat (limited to '')
-rw-r--r--hm/soispha/pkgs/scripts.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/hm/soispha/pkgs/scripts.nix b/hm/soispha/pkgs/scripts.nix
index 5bcb82e0..6598880d 100644
--- a/hm/soispha/pkgs/scripts.nix
+++ b/hm/soispha/pkgs/scripts.nix
@@ -105,6 +105,22 @@
     };
   };
 
+  git-edit-index-scr = write_shell {
+    name = "git-edit-index";
+    path = "apps";
+    # This starts neovim, wich might want to shell out
+    keepPath = true;
+    dependencies = builtins.attrValues {
+      inherit
+        (pkgs)
+        git
+        gnused
+        # $EDITOR
+
+        ;
+    };
+  };
+
   hibernate-scr = write_shell {
     name = "hibernate";
     path = "wrappers";
@@ -309,6 +325,7 @@ in [
   con2pdf-scr
   description-scr
   fupdate-scr
+  git-edit-index-scr
   hibernate-scr
   ll-scr
   lock-scr