about summary refs log tree commit diff stats
path: root/hm/soispha/pkgs/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2024-02-24 14:59:50 +0100
committerSoispha <soispha@vhack.eu>2024-02-24 15:04:49 +0100
commit8284b6a7b4d212913083b003a819fda8d4931d4d (patch)
tree1a41cb60fe64f3f9b1a8c33bd2895ad419366cb5 /hm/soispha/pkgs/default.nix
parentfix(hm/pkgs/git-update-index): Remove '--' from help text (diff)
downloadnixos-config-8284b6a7b4d212913083b003a819fda8d4931d4d.zip
refactor(hm/pkgs): Implement with an nixpkgs overlay
Diffstat (limited to '')
-rw-r--r--hm/soispha/pkgs/default.nix31
1 files changed, 26 insertions, 5 deletions
diff --git a/hm/soispha/pkgs/default.nix b/hm/soispha/pkgs/default.nix
index 4aa5a48c..1c1df7a8 100644
--- a/hm/soispha/pkgs/default.nix
+++ b/hm/soispha/pkgs/default.nix
@@ -1,8 +1,6 @@
 {
   pkgs,
   lib,
-  sysLib,
-  config,
   ...
 }:
 with pkgs; let
@@ -13,8 +11,6 @@ with pkgs; let
     '';
   mpc-cli-man = onlyShare mpc-cli;
 
-  shell-scripts = (import ./scripts.nix) {inherit pkgs lib sysLib config;};
-
   Gui = {
     Terminals = [
       # foot # wayland native terminal
@@ -48,6 +44,32 @@ with pkgs; let
   };
 
   TuiCli = {
+    ShellScripts = [
+      aumo
+      battery
+      con2pdf
+      description
+      fupdate
+      git-edit-index
+      hibernate
+      ll
+      lock
+      lyrics
+      mpc-fav
+      mpc-rm
+      mpc
+      nato
+      neorg
+      screenshot_persistent
+      screenshot_temporary
+      show
+      sort_song
+      spodi
+      update-sys
+      virsh-del
+      yti
+    ];
+
     EyeCandy = [
       #banner # Print large banners to ASCII terminals
       cmatrix # A curses-based scrolling 'Matrix'-like screen
@@ -147,7 +169,6 @@ with pkgs; let
 in {
   home.packages =
     []
-    ++ shell-scripts
     ++ (with builtins;
       concatLists
       (concatLists [