about summary refs log tree commit diff stats
path: root/hm/soispha/conf/taskwarrior/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-10-03 20:21:04 +0200
committerSoispha <soispha@vhack.eu>2023-10-03 20:21:04 +0200
commit603158c6a7ded34e839353299801ccd34a31a2e0 (patch)
tree749a8d437c1884e224b9a19ac34930cf841c68e1 /hm/soispha/conf/taskwarrior/default.nix
parentfeat(hm/conf/taskwarrior/projects): Add support for nested projects (diff)
downloadnixos-config-603158c6a7ded34e839353299801ccd34a31a2e0.zip
fix(hm/conf/taskwarrior/hooks/policies): Also check subprojects
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/taskwarrior/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/hm/soispha/conf/taskwarrior/default.nix b/hm/soispha/conf/taskwarrior/default.nix
index 7482efa8..f2ca65a9 100644
--- a/hm/soispha/conf/taskwarrior/default.nix
+++ b/hm/soispha/conf/taskwarrior/default.nix
@@ -39,7 +39,7 @@
     mkProject = project: subproject:
       if builtins.isString subproject
       then {
-        name = "${project.name}.${subproject}";
+        name = "${project.name}_${subproject}";
         neorg_path =
           if builtins.hasAttr "neorg_path_prefix" project
           then "${project.neorg_path_prefix}/${subproject}/index.norg"
@@ -48,7 +48,7 @@
       else let
         name = builtins.elemAt (builtins.attrNames subproject) 0;
       in {
-        name = "${project.name}.${name}";
+        name = "${project.name}_${name}";
         neorg_path_prefix = "${project.prefix}/${project.name}/${name}";
         subprojects = builtins.elemAt (builtins.attrValues subproject) 0;
       };