about summary refs log tree commit diff stats
path: root/hm/soispha/conf/taskwarrior/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-10-01 13:48:42 +0200
committerSoispha <soispha@vhack.eu>2023-10-01 13:54:50 +0200
commit4d8f53f3de585261124c5147fbe39f704a5eeaf3 (patch)
tree3783f130a546c61230b96e4ec289f56511c02d1b /hm/soispha/conf/taskwarrior/default.nix
parentchore(version): v1.14.0 (diff)
downloadnixos-config-4d8f53f3de585261124c5147fbe39f704a5eeaf3.zip
feat(hm/conf/taskwarrior): Add first config for neorg ⇄ taskwarrior interop
Diffstat (limited to '')
-rw-r--r--hm/soispha/conf/taskwarrior/default.nix35
1 files changed, 32 insertions, 3 deletions
diff --git a/hm/soispha/conf/taskwarrior/default.nix b/hm/soispha/conf/taskwarrior/default.nix
index 803d2d5d..78bcacd0 100644
--- a/hm/soispha/conf/taskwarrior/default.nix
+++ b/hm/soispha/conf/taskwarrior/default.nix
@@ -1,10 +1,39 @@
 {...}: {
-  programs.taskwarrior = {
+  programs.taskwarrior = let
+    mkContext = project: {
+      inherit (project) name;
+      value = {
+        read = "project:${project.name}";
+        write = "project:${project.name}";
+        rc = {
+          neorg_path = "${project.prefix}/${project.name}/index.norg";
+        };
+      };
+    };
+    context = builtins.listToAttrs (builtins.map mkContext (import ./projects {}));
+  in {
     enable = true;
-    colorTheme = "dark-blue-256";
     config = {
       news.version = "2.6.0";
-      # TODO: Add something here <2023-09-30>
+      complete.all.tags = true;
+      list.all = {
+        projects = true;
+        tags = true;
+      };
+      regex = true;
+      weekstart = "Monday";
+      uda = {
+        neorg = {
+          type = "string";
+          label = "Neorg";
+        };
+      };
+      color = true;
+
+      inherit context;
     };
+    extraConfig = ''
+      include ${./nord.theme}
+    '';
   };
 }