about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorene <ene@sils.li>2023-02-21 12:27:53 +0100
committerene <ene@sils.li>2023-02-21 12:27:53 +0100
commit78685e847a282f132057ebe0bac20ddba186d518 (patch)
tree2b392b6321918008dcdff8c4f8c7f53275026557 /flake.nix
parentFix(system): Fix typo in fs names (diff)
downloadnixos-config-78685e847a282f132057ebe0bac20ddba186d518.zip
Feat(bootstrap): Add a setup script
Diffstat (limited to '')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 4b05e87d..5fddd222 100644
--- a/flake.nix
+++ b/flake.nix
@@ -76,6 +76,10 @@
         inherit pkgs;
         inherit (inputs) shell-library;
       };
+      setup = import ./bootstrap/setup {
+        inherit pkgs;
+        inherit (inputs) shell-library;
+      };
     };
 
     apps."${system}" = {
@@ -87,6 +91,10 @@
         type = "app";
         program = "${self.packages."${system}".activate}/bin/activate";
       };
+      setup = {
+        type = "app";
+        program = "${self.packages."${system}".setup}/bin/setup";
+      };
       default = self.apps."${system}".activate;
     };
   };