# yt - A fully featured command line YouTube client
#
# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
# SPDX-License-Identifier: GPL-3.0-or-later
#
# This file is part of Yt.
#
# You should have received a copy of the License along with this program.
# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.

{
  lib,
  rustPlatform,
  ytcc,
  yt-dlp,
  mpv,
  makeWrapper,
}:
rustPlatform.buildRustPackage {
  pname = "yt";
  version = "0.1.0";

  src = ./.;
  cargoLock = {
    lockFile = ./Cargo.lock;
  };

  buildNoDefaultFeatures = true;
  buildFeatures = ["yt"];

  nativeBuildInputs = [
    makeWrapper
  ];

  postInstall = ''
    wrapProgram $out/bin/yt \
      --prefix PATH : ${lib.makeBinPath [mpv yt-dlp ytcc]}
  '';
}