about summary refs log tree commit diff stats
path: root/package/blake3/blake3.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--package/blake3/blake3.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/package/blake3/blake3.nix b/package/blake3/blake3.nix
deleted file mode 100644
index 3965112..0000000
--- a/package/blake3/blake3.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-# yt - A fully featured command line YouTube client
-#
-# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This file is part of Yt.
-#
-# You should have received a copy of the License along with this program.
-# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
-{
-  python3Packages,
-  rustPlatform,
-  fetchFromGitHub,
-}:
-python3Packages.buildPythonPackage rec {
-  pname = "blake3";
-  version = "0.4.1";
-
-  src = fetchFromGitHub {
-    owner = "oconnor663";
-    repo = "blake3-py";
-    rev = version;
-    hash = "sha256-Ju40ea8IQMOPg9BiN47BMmr/WU8HptbqqzVI+jNGpA8=";
-  };
-
-  patches = [
-    ./add_cargo_lock.patch
-  ];
-
-  cargoDeps = rustPlatform.fetchCargoVendor {
-    inherit src patches;
-    hash = "sha256-Woz0f869td1SyRaVw6qVpBW4aJC/5M/tkmxgLR6HDN4=";
-  };
-
-  format = "pyproject";
-
-  nativeBuildInputs = with rustPlatform; [cargoSetupHook maturinBuildHook];
-}