about summary refs log tree commit diff stats
path: root/crates/termsize/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/termsize/Cargo.toml')
-rw-r--r--crates/termsize/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/crates/termsize/Cargo.toml b/crates/termsize/Cargo.toml
new file mode 100644
index 0000000..940f7aa
--- /dev/null
+++ b/crates/termsize/Cargo.toml
@@ -0,0 +1,33 @@
+# yt - A fully featured command line YouTube client
+#
+# Copyright (C) 2025 softprops <d.tangren@gmail.com>
+# SPDX-License-Identifier: MIT
+#
+# This file is part of Yt.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
+
+[package]
+name = "termsize"
+authors = ["softprops <d.tangren@gmail.com>"]
+description = "Retrieves terminal size"
+repository = "https://github.com/softprops/termsize"
+homepage = "https://github.com/softprops/termsize"
+documentation = "http://softprops.github.io/termsize"
+keywords = ["tty", "terminal", "term", "size", "dimensions"]
+license = "MIT"
+readme = "README.md"
+version.workspace = true
+edition.workspace = true
+rust-version.workspace = true
+publish = false
+
+[target.'cfg(unix)'.dependencies]
+libc = "0.2"
+
+[target.'cfg(windows)'.dependencies]
+winapi = { version = "0.3", features = ["handleapi", "fileapi", "wincon"] }
+
+[lints]
+workspace = true