about summary refs log tree commit diff stats
path: root/crates/fmt/Cargo.toml
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-02-16 18:06:15 +0100
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2025-02-16 18:08:10 +0100
commit7cfa6939deb5496a07313a2a34632da1a3fb1b89 (patch)
tree2eb43066ea6e8d14079be1da10f9c5856282e676 /crates/fmt/Cargo.toml
parentchore(crates/termsize): Vendor (diff)
downloadyt-7cfa6939deb5496a07313a2a34632da1a3fb1b89.zip
refactor(crates/fmt): Init forked `uu_fmt` library
Diffstat (limited to 'crates/fmt/Cargo.toml')
-rw-r--r--crates/fmt/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/crates/fmt/Cargo.toml b/crates/fmt/Cargo.toml
new file mode 100644
index 0000000..7f82a09
--- /dev/null
+++ b/crates/fmt/Cargo.toml
@@ -0,0 +1,30 @@
+# yt - A fully featured command line YouTube client
+#
+# Copyright (C) 2025 Benedikt Peetz <benedikt.peetz@b-peetz.de>
+# Copyright (C) 2025 uutils developers
+# SPDX-License-Identifier: MIT
+#
+# This file is part of Yt.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
+
+[package]
+name = "uu_fmt"
+authors = ["uutils developers", "Benedikt Peetz <benedikt.peetz@b-peetz.de>"]
+license = "MIT"
+description = "A fork of the uutils fmt tool. This fork is a library instead of a binary."
+version.workspace = true
+edition.workspace = true
+repository.workspace = true
+rust-version.workspace = true
+publish = false
+
+[lib]
+path = "src/fmt.rs"
+
+[dependencies]
+unicode-width = "0.2.0"
+
+[lints]
+workspace = true