summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 6fb467e..d9ccd27 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,7 +2,7 @@
   description = "NixOS flake for my website";
 
   inputs = {
-    nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.11-small";
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
     systems.url = "github:nix-systems/x86_64-linux";
     flake-utils = {
       url = "github:numtide/flake-utils";
@@ -12,11 +12,19 @@
       url = "github:hakimel/reveal.js";
       flake = false;
     };
+    essay = {
+      url = "git+https://codeberg.org/bpeetz/kant_and_free_software.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        systems.follows = "systems";
+      };
+    };
   };
 
   outputs = {
     nixpkgs,
     flake-utils,
+    essay,
     ...
   }:
     flake-utils.lib.eachDefaultSystem (
@@ -35,7 +43,9 @@
             allowSubstitutes = false;
 
             nativeBuildInputs = [];
-            buildPhase = "";
+            buildPhase = ''
+              cp ${essay.outputs.packages."${system}".default}/philosophy/kant_and_free_software.pdf ./dead-trees/kant_and_free_software.pdf
+            '';
             installPhase = ''
               install -d $out/
               cp -r . $out/